SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, iOS Chart, Android Chart and JavaScript Chart Components

Answered
1
0

Hi,

I’d like to update the iOS version to the latest stable one (4.1.0), but after following the steps here: https://www.scichart.com/documentation/ios/current/integrating-scichart-libraries.html
Xcode keeps complaining:

framework not found SciChart.xcframework
clang: error: linker command failed with exit code 1

If I downgrade back to 3.1.1 everything works again. Any idea why the version 4.1.0 is not working? I’m using Pods to manage all dependencies.

Version
4.1.0
  • You must to post comments
Best Answer
1
0

Hi, Erika.

In order to install SciChart v.4 via CocoaPods you need to have CocoaPods version >= 1.10.0.rc.1.

You can install it using this command:

sudo gem install cocoapods -v 1.10.0.rc.1

To check your CocoaPods version use this command:

pod --version

In the meantime, you can install it manually by downloading a zip directly from the release assets and drag SciChart.xcframework to your project manually.

Another way is to use SPM (which has it’s own issues and limitations):
https://www.scichart.com/documentation/ios/current/integrating-scichart-libraries.html#integrating-scichart-via-swift-package-manager

Let us know if it works for you

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.