Pre loader

Failure to update to from 3.1.1 to 4.1.0

Welcome to the SciChart Forums!

  • Please read our Question Asking Guidelines for how to format a good question
  • Some reputation is required to post answers. Get up-voted to avoid the spam filter!
  • We welcome community answers and upvotes. Every Q&A improves SciChart for everyone

WPF Forums | JavaScript Forums | Android Forums | iOS Forums



I’d like to update the iOS version to the latest stable one (4.1.0), but after following the steps here:
Xcode keeps complaining:

framework not found SciChart.xcframework
clang: error: linker command failed with exit code 1

If I downgrade back to 3.1.1 everything works again. Any idea why the version 4.1.0 is not working? I’m using Pods to manage all dependencies.

  • You must to post comments
Best Answer

Hi, Erika.

In order to install SciChart v.4 via CocoaPods you need to have CocoaPods version >= 1.10.0.rc.1.

You can install it using this command:

sudo gem install cocoapods -v 1.10.0.rc.1

To check your CocoaPods version use this command:

pod --version

In the meantime, you can install it manually by downloading a zip directly from the release assets and drag SciChart.xcframework to your project manually.

Another way is to use SPM (which has it’s own issues and limitations):

Let us know if it works for you

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.