SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and iOS Chart & Android Chart Components

0
0

Have recently converted to xcode 10 and swift 4.2.

Am now receiving this error message on build.

SciChart.framework/SciChart
Reason: no suitable image found. Did find:
/usr/lib/libstdc++.6.dylib: mach-o, but not built for iOS simulator

Any ideas?

Version
SciChart(2.2.0.2252)
  • Andrew
    Hi Russ. SciChart iOS v2.2.0 and above is compatible with iOS 12. Please see the app store here & try out our published examples app on your device. https://itunes.apple.com/ua/app/scichart-examples/id1265132167?mt=8 If you experience problems it may be because you are using an older version of SciChart and don’t realise, or, some other configuration or deployment issue in your application.
  • You must to post comments
1
0

Hello, Russ. SCIChart 2.2.0.2252 is definitely not using libstdc++ anymore. Deprecated libstdc++ library was replaced with libc++ in SciChart v2.2.0, so please make sure you’re using the most recent version of SCIChart framework, clean out your xCode Derived Data folder, update cocoa pods. I assume that could be just some xCode caching issue.

We also have a version of the SciChart iOS Examples suite published on the app store, which we have tested and works in iOS 12 so we are certain that the v2.2.0 and above is compatible with XCode 10.

Regards, Andriy.
SciChart iOS developer.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.