Pre loader

iOS Simulator Issue

Welcome to the SciChart Forums!

  • Please read our Question Asking Guidelines for how to format a good question
  • Some reputation is required to post answers. Get up-voted to avoid the spam filter!
  • We welcome community answers and upvotes. Every Q&A improves SciChart for everyone

WPF Forums | JavaScript Forums | Android Forums | iOS Forums


I was testing my charts on a simulator and when I naved away and then back to the chart screen the Simulator’s chart was totally black screen; I could move the mouse over the points and the popouts would occur; and your license notice showed in the center of the chart. So it was almost like it thought all the drawing for the chart itself needed to be black on black.

It was always broken on the 2nd or later chart. Restarting the app fixed it. I tried removing all custom settings, and calling the invalidate; and nothing caused it to redraw correctly… Fortunately, when deploying to real devices everything worked correctly. Is this an expected side effect of testing on a simulator, or is their something that I can do to force a hard refresh of the chart…

FYI: The additional debug diagnostics don’t seem to do anything on a simulator, or at least I couldn’t find anywhere it was logged.

  • Andrew Burnett-Thompson
    Hi Nathanael, dev team says there seems to be a problem in our Metal implementation of the 2D/3D engine in the simulator, they will create a task and investigate. Should work fine on real device, which is preferably anyway as the hardware acceleration of iOS simulators is appalling! …
  • You must to post comments

Hi Nathanael.
As Andrew mentioned, there is some internal issue in the OpenGL implementation of the 2D/3D engine. Because OpenGL is deprecated and considered to be a quite low priority – all I can do for now – is create a bug in our bug tracker ( so someone will pick it up and investigate/fix the issue.
We will keep you updated on the above issue progress and will let you know when it is fixed.

  • Nathanael Anderson
    This is NOT a high priority at all; just was something I was letting you know — and something you MIGHT want to put in the readme’s. It worried me initially because it is a lot easier to test on a simulator (even with crappy performance) and so I was worried that the chart itself was configured incorrectly and I couldn’t find any settings that would fix it. And I knew the client would never accept a chart that worked once… :) Once I realized it was just a simulator issue, it really is not a big issues, just an annoyance…
  • You must to post comments

Hi, there.

We’ve released SciChart 4.1.0 where this issue has been resolved.

You can find more details here:

Fix is available in cocoapods version ‘’ or 4.1.0 via SPM.

Please, try it and let us know the results.

Thanks in advance.

  • You must to post comments

Hello everyone.
This issue is still happening using the latest v3 version ( pod ‘SciChart’, ‘3.1.0-nightly.5287’) for the iOS and we are very unhappy that the charts are black on simulators.
We are trying to produce screenshots for the Appstore using Fastlane automation in order to present nicely to our clients our new tools related to multiple charts and indicators panes and we cannot do it because of this issue.
Can you please suggest any quick fix or push your team to fix it ASAP ?

Thanks a lot for your support

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.