SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and iOS Chart & Android Chart Components

1
0

Hello, I’m having an issue when I put multiple surfaces in an iOS view. Only the one made first is shown and there is a black space in place of the other. I swapped the order of creation and now the other is visible instead. Does anyone know why this is happening or have suggestions for putting multiple surfaces in an iOS view? Thanks

Version
3.1.0.5175
  • Nazar Rudnyk
    hi there, I suspect you are using OpenGL render surface and testing in simulator. That’s a known problem which happens to be the case only with simulator, so please try your set-up on the real device, and let us know if everything is fine there. Best regards, Nazar. R.
  • Yatharth Chhabra
    Hello, thanks for the solution! I ran into an issue while running on an actual device. As soon as I open the app it crashes with Thread 1: signal SIGABRT. I think it may be caused by incorrectly linking the SciChart Framework, but it worked fine on the simulator. I’m pretty sure I connected the framework correctly. Do you have an idea of what could cause this? This is the stacktrace: * thread #1, stop reason = signal SIGABRT * frame #0: 0x000000010537f5e4 dyld`__abort_with_payload + 8 frame #1: 0x0000000105386498 dyld`abort_with_payload_wrapper_internal + 100 frame #2: 0x00000001053864c8 dyld`abort_with_payload + 12 frame #3: 0x0000000105383848 dyld`dyld::halt(char const*) + 380 frame #4: 0x000000010533aff4 dyld`dyld::_main(macho_header const*, unsigned long, int, char const**, char const**, char const**, unsigned long*) + 5192 frame #5: 0x0000000105335208 dyld`dyldbootstrap::start(dyld3::MachOLoaded const*, int, char const**, dyld3::MachOLoaded const*, unsigned long*) + 396 frame #6: 0x0000000105335038 dyld`_dyld_start + 56
  • Brian Harmann
    We are having the same issue in the Sim as you described Nazar. I didn’t want to open another ticket since it seems to be a known issue, but any idea if it’s something you guys plan on fixing?
  • You must to post comments
0
0

Hi, there.

As Nazar has mentioned in the comment we have an issue with rendering multiple charts on one screen using OpenGL. Metal doesn’t have this issue. Since iOS Simulator uses OpenGL you can’t debug multiple charts on the simulator. In case you want us to implement rendering multiple charts using OpenGL, please submit a feature request here https://features.scichart.com/app/#/user/suggest

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.