SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, iOS Chart, Android Chart and JavaScript Chart Components

Answered
1
0

Hi,

I am using SciChart trial version to create a a simple line chart but when running an application for a while, I got this error in the dev console log – not sure what the root cause is but it seems to come from SciChart library

screenshot

Version
2.2.2401
Images
  • You must to post comments
Great Answer
0
0

Hi Atanai,

We believe we have an answer for you but we need you to confirm if the machines having problems have Intel HD graphics adapters? If so, this could be a machine specific issue caused by Intel driver bug.

We had problems before with Intel HD GPUs also with WebGL context lost and Function Signature Mismatch. Here are some links to forum posts

SciChart Forums

Intel Forums

from the Intel forums

Have same issue with SciChart.js
Had test with two pc.
No error with UHD 630 / v 27.20.100.8681.
Error with UHD 630 / v 27.20.100.8783.
v.8681 is released only 20 days earlier than v 8783.
Hope there’s any progress.

Using the latest version of the driver (30.0.101.1994) this issue described above is not reproducible.
Unless there is an specific reason to use the v 27.20.100.8783, please upgrade to the latest.
Closing the topic
Arturo

Our suggestion is to check the machines having problems, check if they have Intel graphics adapters and to check the driver versions. Ensure they are updated to the latest version (30.0.101.1994 or later). This will resolve problems with WebGL on these machines.

Please let me know if the above helped

Best regards
Andrew

  • You must to post comments
0
0

Hi Andrew,

My colleague is back!

The machine is having Intel(R) UHD Graphics 620 and the driver version is 27.20.100.9126

Thanks

  • Andrew Burnett-Thompson
    Alright great! There is a known issue with Intel UHD graphics drivers and WebGL. This should be fixed in v 30.0.101.1994. Can you ask your colleague to update graphics driver and try again?
  • You must to post comments
0
0

I will check with my colleague once he returns from vacation – next week.

I see one thing (weird?) where .wasm file is loaded twice – see attached. Not sure if this relates to the issue but just wanted to share.

Images
  • Andrew Burnett-Thompson
    We would have to have code to reproduce this problem – if it is our code, please share where. If it is your code, please share that with our team by emailing support [at] scichart [dot] com. Best regards, Andrew
  • You must to post comments
1
0

Hi Andrew,

The issue is not easy to replicate and it happened only on one of my colleague’s machine. Not sure if it is machine specific?
I can see lots of warning message before ‘Function or function signature mismatch’ error – see new attached screenshot

Images
  • Andrew Burnett-Thompson
    Hi Atanai, does your colleague have Intel HD graphics by any chance? What driver version? If so I may have a solution for you
  • You must to post comments
1
0

Hi Andrew,

How can I check if the wasm file is incorrect version?

I recently did not update the SciChart. I use the wasm file from SciChart inside node_modules. Here is the script to copy wasm file from node_modules to ./src folder

{
“copyFilesSettings”: {
“whenFileExists”: “overwrite”
},
“copyFiles”: [
{
“from”: “./node_modules/scichart/_wasm/scichart2d.data”,
“to”: “./src/scichart2d.data”
},
{
“from”: “./node_modules/scichart/_wasm/scichart2d.wasm”,
“to”: “./src/scichart2d.wasm”
}
]
}

  • Andrew Burnett-Thompson
    Hi Atanai, I still don’t have enough information to reproduce the info. Does this occur in any of our examples or your code? If your code – can you provide the code please as an npm project we can run? In your screenshot you have multiple WebGL Context Lost. This might be causing the error above (although scichart.js is designed to recover from WebGL context loss). Please help us reproduce the issue and our team will gladly investigate. Best regards, Andrew
  • Andrew Burnett-Thompson
    Discussing with team, we think this is related to WebGL context loss. But we would need a real example that reproduces it – as we have no open issues we’re aware of that cause WebGL context loss
  • You must to post comments
1
0

Hi Atanai

This looks like you have a mismatch between the SciChart.js library version and the version of the wasm (WebAssembly) file.

Have you recently updated SciChart? How are you referencing or installing the wasm file?

If you provide more info about how to reproduce this problem or a code sample, we will investigate

Best regards,
Andrew

  • You must to post comments
Showing 6 results
Your Answer

Please first to submit.