Pre loader

SciChart cannot be loaded when the application is opened with Electron (Version 3 only)

Welcome to the SciChart Forums!

  • Please read our Question Asking Guidelines for how to format a good question
  • Some reputation is required to post answers. Get up-voted to avoid the spam filter!
  • We welcome community answers and upvotes. Every Q&A improves SciChart for everyone

WPF Forums | JavaScript Forums | Android Forums | iOS Forums


I am trying to build my application with Electron. When the Electron application is run, it will open the UI in the browser (not opened with chromium). I created two Electron applications with same codes but with different versions of SciChart (i.e. version 2 and version 3). When I run with the Electron application with SciChart v2, the SciChart can be loaded properly. When when I run the Electron application with SciChart v3, I got error (please refer to the screenshot) and the SciChart cannot be loaded. I am not sure what’s wrong. Do you have any idea?

  • Andrew Burnett-Thompson
    Hi Quyen, there seems to be some problems with our boilerplate for Electron over on Github, but we are aware of it and are working on it. Will update you soon with some info.
  • You must to post comments

Hi Quyen

We’ve updated our Electron Boilerplate in Github. Find the latest version here.

One thing we had to change to work with SciChart.js v3 was adding a Webpack plugin to allow connection to the SciChart licensing wizard. You can find this in forge.config.ts

Can you try that? Any more questions just let us know

Best regards,

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.