Pre loader

ZoomPanModifier Zoomout showing NaN on the scale.

Welcome to the SciChart Forums!

  • Please read our Question Asking Guidelines for how to format a good question
  • Some reputation is required to post answers. Get up-voted to avoid the spam filter!
  • We welcome community answers and upvotes. Every Q&A improves SciChart for everyone

WPF Forums | JavaScript Forums | Android Forums | iOS Forums


ZoomPanModifier date format charts zoom out continuously then showing NaN on the scale. It happened because the zoom level goes under the invalid date. Can you add the Minimum Zoom/Pan and Maximum Zoom/Pan area to be configured on options?

  • You must to post comments

Hi Arun,

Thank you for the suggestion about ZoomPanModifier zooming out. We released version 1.2.1428 and it fixes this NaN issue for ENumericFormat.Date formats. If while zooming out visible range exceeds possible data values, the labels become hidden. Moreover it is possible now to set visibleRangeLimit to some value to limit the visible range while zooming out.

const { sciChartSurface, wasmContext } = await SciChartSurface.create(divElementId);
const xAxis = new CategoryAxis(wasmContext);
xAxis.labelProvider.numericFormat = ENumericFormat.Date_HHMM;
xAxis.visibleRangeLimit = new NumberRange(1, 10000);

Keep in mind if you are using CategoryAxis then the visible range contain indexes, not values, so it starting from 0.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.