SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy. We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

Please note: SciChart team will only answer questions from customers with active support subscriptions. Expired support questions will be ignored. If your support status shows incorrectly, contact us and we will be glad to help.

0
0

I have an issue where I attempt to zoom/pan with a ZoomPanModifier only in the X direction. At the same time I would like my Yaxis to stay set at my current boundaries. The problem is that when I first load up the chart everything works fine, but when I pan left and right the YAxis auto ranges itself and never uses the current boundaries I have set. And once I’m done zooming the auto Range stays on. Here is the sample code.

<Custom:ZoomPanModifier x:Name="zoomPanModifier" IsEnabled="True" ExecuteOn="MouseRightButton" XyDirection="XDirection" />
<Custom:SciChartSurface.YAxis>
<Custom:NumericAxis DrawMinorGridLines="False" AxisTitle="Value" TextFormatting="#,##0" x:Name="YAxis" AutoRange = "False">
<Custom:NumericAxis.VisibleRange>
<Custom:DoubleRange Min ="0" Max ="2200"></Custom:DoubleRange>
</Custom:NumericAxis.VisibleRange>
<Custom:NumericAxis.GrowBy>
<Custom:DoubleRange Min="0.1" Max="0.1"/>
</Custom:NumericAxis.GrowBy>
</Custom:NumericAxis>
</Custom:SciChartSurface.YAxis>

Would like to know If maybe I’m setting the auto range somewhere else I don’t know about or this problem is recreatable on your side. Thanks.

  • You must to post comments
0
0

Hi there,

This is the default behaviour of the ZoomPanModifier when dragging in X-Direction is enabled, that it also Zooms to Extents the Y-Axis while you pan.

However, it has been requested that we allow users to disable this, so we’ve added in a new property, ZoomPanModifier.ZoomExtentsY (default true), which when set to false, disables this feature of auto-ranging on Y-Axes as you pan in the X Direction.

This will be released as part of SciChart v1.6 very soon – in fact, we’re just testing the final release package now.

Best regards,
Andrew

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.