SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy. We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

Please note: SciChart team will only answer questions from customers with active support subscriptions. Expired support questions will be ignored. If your support status shows incorrectly, contact us and we will be glad to help.

0
0

Hi,

I’m binding SciChart to a ViewModel in the following way:

<sciChart:SciChartSurface DataSet="{Binding Path=ChannelDataSet}"
RenderableSeries="{Binding Path=ChannelSeries}"
XAxis="{Binding Path=TimeAxis}"
YAxes="{Binding Path=YAxisCollection}" />

The YAxisCollection contains three IAxis objects with three different VisibleRanges. The problem is that the set VisibleRanges are ignored by the chart while setting AutoRange to false. I get three Y-Axis on the chart, but the VisibleRange seems to be automatic. What am I doing wrong in my Bindings?

I attached a sample project that points out the issue!

Thanks

  • You must to post comments
0
0

Hi there,

Could you try out to set SciChartSurface.AutoRangeOnStartup=”False”?
Please, let me know if this helps!

Best regards,
Yuriy

  • joerg
    That does the trick!Thanks!!
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.