SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy

We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

0
0

I am evaluating the SciChart package and I am trying to show a graph of data. The data changes about every 500ms. I have the code as shown below.

My XAML code is:

                            <s:SciChartSurface  Name="Chart1">
                            <s:SciChartSurface.RenderableSeries>
                                <s:FastLineRenderableSeries DataSeries="{Binding SpectrumDataSciChart}" Name="lineRenderSeries"/>
                            </s:SciChartSurface.RenderableSeries>
                            <s:SciChartSurface.XAxis>
                                <s:NumericAxis ScientificNotation="None" />
                            </s:SciChartSurface.XAxis>
                            <s:SciChartSurface.YAxis>
                                <s:NumericAxis  />
                            </s:SciChartSurface.YAxis>
                        </s:SciChartSurface>

SpectrumDataSciChart is defined in the view model (.cs) as below:

        private XyDataSeries<double, double> _spec2;
    public XyDataSeries<double,double> SpectrumDataSciChart
    {
        get { return _spec2; }
        set { _spec2 = value; NotifyPropertyChanged(); }
    }

I see the correct plot but then the plot is removed (just a blank chart) and then it appears again. Seems like it is when I update the data (setting SpectrumDataSciChart to a new set of values). I don’t see this behavior with other vendors charts and wondering if I need to set something on the chart or bind differently. I tried using “FastLineRenderableSeriesForMvvm” (as I am using MVVM with WPF) also but it does the same thing. Any ideas?

Version
Trial version
  • You must to post comments
0
0

We don’t see this behaviour either in our examples, or reported by any other users!

I wonder what other settings you have on the chart, what your hardware is, operating system, GPU driver etc…

There is one known issue with a workaround:

SciChart 2D Troubleshooting

Some users report glitches, flickering or a freezing screen when using the
software renderers. We have identified that some graphics hardware,
particularly Intel HD GPUs, has a bug which affects the WPF
WriteableBitmap class.

Some users report
glitches and flickering when using the DirectX hardware renderer. The
first thing we suggest is that people upgrade their graphics drivers
as out of date Graphics drivers can be a cause of glitches in our
Direct3D10RenderSurface.

Some solutions on the above page. Maybe that is the issue for you? Only if you’re using DirectX.

Best regards,
Andrew

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.