SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy

We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

0
0

I found the one line of code to request a print from a scichart surface. However, when I would run it, I found that it had cut off the bottom portion such that you didn’t get the X axis numbers to show. After playing with different approaches it seems that the printing is somewhat dependent on my margins and what the current width and height are of the surface. I was eventually able to come up with something that has the full plot show up in an xps file. When I print to my printer it clips off part of it still. Does anyone have some direction on how to get this to work with whatever printer may be selected? Do I have to try and find another way?

Version
4.2.4
  • You must to post comments
0
0

Hi Richard,

If SciChart exports to XPS but the XPS file still prints with the bottom cropped, it sounds like a printer settings issue?

  • You must to post comments
0
0

Hello Richard,

I have few questions for you:

[1] How do you call Export method? Do you specify any different Size? or you export as it is ?

[2] It could be something related to your printer settings

Best Regards,

  • Brian Dawber
    I’m having a similar problem. When printing via the SciChartSurface.Print(), the print to our Xerox severely crops the image (depending on orientation). The Xerox doesn’t have any obvious scaling options other than pages per sheet (which is set to 1). Cropping doesn’t occur using the print dialog to XPS or pdf, and printing the generated XPS results in no cropping and a properly scaled image.
  • You must to post comments
0
0

I don’t really want to be printing to xps (exporting). I just want to have it print the chart to a printer without cropping and it just doesn’t work. I don’t have any real control over the printing so I don’t know what I can do to fix it.
I’m not sure what you mean by printer settings being the issue. There’s not a whole lot I can change. It seems that the size of my chart affects the printing. That does not seem correct to me. I would just like it to fit the printer.
How does anyone get the print to work correctly?

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.