SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy. We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

Please note: SciChart team will only answer questions from customers with active support subscriptions. Expired support questions will be ignored. If your support status shows incorrectly, contact us and we will be glad to help.

0
0

I’m trying to plot a vertical bar (column) chart where each bar represents a chemical element. Rather than the bars being “side by side”, using (say) an incrementing X value (1,2,3…), I was hoping I could use the chemical elements’ masses, resulting in a chart where the bars are “spread out” along the X-axis in a non-uniform way.

Here are some example X-values from a series I’m trying to plot – while the first few are fairly uniform, note the large gap before the last two:-

201.970627
202.972336
203.972
204.972
205.974457
206.975876
207.976639
235.043915
238.050781

If I try and render these using a FastColumnRenderableSeries, it starts off okay but goes a bit crazy with the last couple of bars! As I understand it, this series type doesn’t support gaps in the data, so I’m assuming this is to blame for the corrupt display.

Can you suggest any alternative approaches to what I’m trying to achieve? I’ve tried the FastImpulseRenderableSeries, which gives results very close to what I’m looking for. Unfortunately the inability to make the impulse lines wider is a showstopper for the client.

  • You must to post comments
0
0

Hi Andy,

Please, try setting UniformWidth to “True”, it configures the series to draw columns using the width of the thinnest column. Also, please, take a look at this post, you might find there some useful info.

Please, let us know if it helps!

Best regards,
Yuriy

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.