SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

0
0

Hi ,
I have created a CustomFastLineRenderableSeries which inherits from FastLineRenderableSeries to be able to create custom data point shapes. Everything was good with Y-axis zoom but as soon as i enabled X-axis zoom, looks like the datapoints disappear on zoom-in.

Also i’m getting below exception on zoom which might be related:

Index was outside the bounds of the array.
Exception thrown: ‘System.IndexOutOfRangeException’ in SciChart.Data.dll

Any idea on this? Should limit xvisibleRange?

Version
4
Images
  • You must to post comments
0
0

Hi Aysan,

I suspect that the Custom Renderable Series you’ve created is throwing this exception. Are you able to post the stack trace and/or the code?

Best regards,
Andrew

  • You must to post comments
0
0

Andrew,
I attached CustomFastLineRenderableSeries file for you.
The error i sent you, i see it in the output window. There is no more details or stack trace unfortunately.

  • You must to post comments
0
0

Hi Aysan,

Thanks for posting your code here. The problem is that you use IPointSeries.Indexes to walk through the PointSeries, which is incorrect. As the comment to the property says, the Indexes property

Gets the indexes of points in the original DataSeries

So these indexes belongs to DataSeries which you assigned to RenderableSeries, not to PointSeries which you receive in the InternalDraw method. The difference is that PointSeries may contain a resampled (reduced) data, and the Indexes property is required to keep a connection to the original DataSeries.

What you should do, is just enumerate PointSeries itself in a loop.

Alternatively, you could switch resampling off setting ResamplingMode to “None” on your series.

Please try it and let us know if everything works OK,

Best regards,
Yuriy

  • Aysan Afrand
    Thanks Yuriy. I changed my loop to enumerate PointSeries and looks good now.
  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.