SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy

We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

0
0

Hi im getting some errors when I add the scichart modules as dependencies

My project dependencies currently look like…

compile fileTree(include: ['*.jar'], dir: 'libs')
compile 'com.android.support:support-v4:24.2.0'
compile 'com.android.support:appcompat-v7:24.2.0'
compile 'com.android.support:gridlayout-v7:24.2.0'
compile 'com.android.support:design:24.2.0'
apt 'com.jakewharton:butterknife-compiler:8.2.1'
compile 'com.jakewharton:butterknife:8.2.1'
compile 'com.squareup.retrofit2:retrofit:2.1.0'
compile 'com.squareup.retrofit2:adapter-rxjava:2.1.0'
compile 'com.squareup.retrofit2:converter-gson:2.0.0-beta3'
compile 'com.squareup.okhttp3:logging-interceptor:3.3.0'
compile 'io.reactivex:rxjava:1.1.8'
compile 'io.reactivex:rxandroid:1.2.1'
testCompile 'junit:junit:4.12'
testCompile 'org.mockito:mockito-core:1.10.19'


compile project (':charting-release')

But when I had the ‘charting release’ module I get

error…
Error:(112) Attribute “orientation” already defined with incompatible format.

specifically relating to…

As im using gridlayout as a dependence in my project, I wondered if there might be some kind of conflict between it and the charting release module.

I’ve tried…
compile project (‘:charting-release’){
exclude module: ‘support-v7’
}

But to no avail.

Thanks
Aidan

Version
3
  • Aidan Mack
    Basically if I add compile ‘com.android.support:gridlayout-v7:24.2.0’ as a dependency with…compile project(‘:charting-release’) compile project(‘:core-release’) compile project(‘:data-release’) compile project(‘:drawing-release’)Then I get this errorError:(112) Attribute “orientation” already defined with incompatible format.
  • Aidan Mack
    I dont think I added the modules correctly. Last time they were not in my libs directory. Ive dont so and it hasnt made any diffrence.compile ‘com.android.support:gridlayout-v7:24.2.0′ // Declare SciChart libraries as module dependencies compile (name:’charting-release’, ext:’aar’) compile (name:’drawing-release’, ext:’aar’) compile (name:’data-release’, ext:’aar’) compile (name:’core-release’, ext:’aar’)addthe support for gridlayout still kills it.
  • You must to post comments
0
0

Hi Aidan,

This issue is resolved in build v1.1.1.1345 (or later) of SciChart Android. We have sent you a copy of the binaries directly and the fix will be included in future public releases of SciChart.

Thanks for reporting!

Best regards,
Andrew

  • Aidan Mack
    Thanks Andrew, I dont think my work email picked up on it. if its a zip, its probably deleted it. Please could you forward to aidanmack@hotmail.comThanks Aidan
  • Andrew
    That’s nice of them :) Ok I’m doing this now ..
  • Andrew
    Actually, if you go to http://support.scichart.com -> login -> click on My Tickets you should be able to see the reply + attachment there. Best regards, Andrew
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.