SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy

We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

1
0

To whom this may concern:

I am having an issue setting the axis alignment with your 2D Heatmap series. I have tested this with your “Heatmap Chart” sample from your Examples Suite.

Lines 44-50 are shown below from your “HeatMapExampleView” XAML file. I have added the AxisAlignment parameters as shown.

<s:SciChartSurface.XAxis>
    <s:NumericAxis AxisAlignment="Left" DrawMajorBands="True" />
</s:SciChartSurface.XAxis>

<s:SciChartSurface.YAxis>
    <s:NumericAxis AxisAlignment="Top" DrawMajorBands="True" />
</s:SciChartSurface.YAxis>

Note how the Y-Axis is aligned to a vertical parameter (Top, in this case) and X-Axis is aligned to a horizontal parameter (Left). This leads to scichart not showing any heatmap at all, as shown in the attached images.

It will work if i set Y to Left or Right, and X to Top or Bottom, but not the other way around.

Can you please advise?

Thanks kindly!

Version
4.1.1.8668
Images
  • You must to post comments
1
0

Hi Ari,

Thank you for reporting this. Please let me log it for us to investigate the incorrect behavior.

May I ask, is this issue urgent for you?

  • Ari Sagiv
    Hi Yuriy —No, this isn’t urgent, I was able to solve the problem with using RenderTransform, but in the future I would like to avoid using that if possible.Thanks!— Ari
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.