SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

0
0

I use a scatter series that contains around 200,000 data points and I noticed that in the DirectX assisted rendering mode (not sure it also applies to the normal non DirectX mode) scatter points are sampled, meaning, not all scatter points are visible on the chart surface.

How can I turn that off to display all data points even if that may affect performance? I chart financial time series and the chart often shows discrete jumps when there are actually many data points in between when zooming in.

Thanks

Version
4.2.2
  • You must to post comments
0
0

Hi there

By default the XyScatterRenderableSeries of SciChart does not resampling data-points.

However, the FastLineRenderableSeries with PointMarker does. To disable resampling for a FastLineRenderableSeries, set FastLineRenderableSeries.ResamplingMode = ResamplingMode.None

There is another feature of SciChart scatter called clustering. This applies to Scatter series only. Pointmarker points of the same type, drawn to the same X,Y location are discarded. This should result in no difference whether its on or off. It can be disabled nevertheless by setting:

 scatterRenderableSeries.PointMarkerBatchingStrategy = new DefaultPointMarkerBatchStrategy();

Best regards,
Andrew

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.