SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy

We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

0
0

I am trying to launch the demo application from VS 2017 but I get the error:
Severity Code Description Project File Line Suppression State
Error This project references NuGet package(s) that are missing on this computer. Enable NuGet Package Restore to download them. For more information, see http://go.microsoft.com/fwlink/?LinkID=322105. The missing file is C:\Users\\AppData\Roaming\SciChart SDK\.nuget\NuGet.targets. SciChart.Examples.Demo C:\Users\\AppData\Roaming\SciChart SDK\Examples\SciChart.Examples.Demo\SciChart.Examples.Demo.csproj 689

Failing section:

  <Target Name="EnsureNuGetPackageBuildImports" BeforeTargets="PrepareForBuild">
    <PropertyGroup>
      <ErrorText>This project references NuGet package(s) that are missing on this computer. Enable NuGet Package Restore to download them.  For more information, see http://go.microsoft.com/fwlink/?LinkID=322105. The missing file is {0}.</ErrorText>
    </PropertyGroup>
    <Error Condition="!Exists('$(SolutionDir)\.nuget\NuGet.targets')" Text="$([System.String]::Format('$(ErrorText)', '$(SolutionDir)\.nuget\NuGet.targets'))" />
  </Target>

Manually restoring NuGet packages returns:
All packages are already installed and there is nothing to restore.

Clearing NuGet cache does not change anything.

Same issue goes for VS 2015

Version
4.2.2.9777
  • You must to post comments
0
0

Hi Soren

Apologies for the long delay with answering this.

To build our source code, you need to add the SciChart NuGet feed to your list of NuGet package sources.

Full instructions can be found at the page Getting Nightly Builds with NuGet.

Best regards,
Andrew

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.