SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and iOS Chart & Android Chart Components

Answered
0
0

Hello

Currently trying this:

final NumericAxis yAxis = sciChartBuilder.newNumericAxis()
            .withAutoRangeMode(AutoRange.Never)
            .withTextFormatting("#.0000")
            .withVisibleRangeLimit(1.143, 1.146)
            .build();

Works perfectly with values .withVisibleRangeLimit(1.14, 1.15), but every time i go for more precision – range is default 0-10

Please help

Edit:
Also works fine with

.withVisibleRangeLimit(1.1433, 1.1566)

Question 2.
Is there a way to determine that live chart was scrolled by finger or by animation (when adding new point)?

Version
2.2.2.2424
  • You must to post comments
Best Answer
1
0

Hi Vadim,

  1. It’s probably caused by default MinimalZoomConstrain value which prevents axis from very deep zoom. Please can you try to set it to 0 which should disable rolling back to default VisibleRange value:

        yAxis.setMinimalZoomConstrain(0d);
    
  2. There is isAnimating flag in VisibleRangeChangeListener which can set for axis:

    yAxis.setVisibleRangeChangeListener(new VisibleRangeChangeListener() {
        @Override
        public void onVisibleRangeChanged(IAxisCore axis, IRange oldRange, IRange newRange, boolean isAnimating) {
    
        }
    });
    

Hope this will help you!

Best regards,
Yura

  • Kirey Vadim
    Thanks a lot. Had an idea to increase my y-values by 1000 to fix it, but that one-liner is perfect.
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.