SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy

We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

Answered
0
0

Hi,

I’m working with FastRenderableLineSeries and realized that re-sizing a graph to be smaller hides some of the series that has a lot of points in them. Is this intended to be like that? I was hoping there was a setting somewhere that I can increase the threshold if that’s the case.

Here’s an example, the disapearing data are separate series. There are a total of 4 series in the graph.

Thanks.

Images
  • You must to post comments
Best Answer
4
0

Thanks to Andrew, setting the ResamplingMode to Auto seems to have fixed the problem

  • Andrew
    Fantastic! :) ResamplingMode.Auto is now the default in v3.x and up. This will detect the distribution of your data (evenly spaced time-series, unevenly spaced time-series, unsorted) and will apply the correct resampling and transformation algorithms. Please note, that sorted data in X is still faster in v3.x but SciChart will always draw correctly with the default (Auto) resampling mode
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.