SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy. We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

Please note: SciChart team will only answer questions from customers with active support subscriptions. Expired support questions will be ignored. If your support status shows incorrectly, contact us and we will be glad to help.

0
0

Hello.

Found a bug: when working with the axis-X scales the Y-axis
To get started, you need to configure in SciChart so zooming and moving only happened on the axis-X

Next:

  1. Take any chart (1.png)
  2. Highly scalable any point (2.png)
  3. Try to move the schedule of shifts sharply to the side, Y-axis scale changes (3.png)
  4. increase the scale to its original condition(4.png)

At the same time if you do everything except the third paragraph then all is well

This is a bug or need to configure something else?

Attachments
Images
  • You must to post comments
0
0

Hi there,

I don’t think this is a bug, you just need to set some properties on the ZoomPanModifier. Try this:

var zoomPanModifier = new ZoomPanModifier()
{
    XyDirection = XyDirection.XDirection,
    ZoomExtentsY = false, // When XyDirection = XyDirection.XDirection, set this flag to false to prevent YAxis from zooming on pan
    ExecuteOn = ExecuteOn.MouseLeftButton, 
    ClipModeX = ClipMode.None, // Prevent XAxis stretching on pan at the edge of your data
};

You can see the properties of ZoomPanModifier here.

The ZoomExtentsY property has this comment:

If true, zooms to extents on the Y-Axis on each zoom operation when
panning in X-Direction only. Use in conjuction with XyDirection to
achieve different zooming effects

Best regards,
Andrew

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.