SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

0
0

After migrating to 4.0.5, I have shadows on my tooltips as below.
Also, the herringbone pattern is new to 4.0.
I have:

  </Border>
</ControlTemplate>


<s:SciChartSurface.ChartModifier>
    <s:ModifierGroup>
      <s:RolloverModifier s:Name="rolloverModifier"
                                    LineOverlayStyle="{StaticResource RolloverLineStyle}"
                                    DrawVerticalLine="True"
                                    SourceMode="AllSeries"
                                    ShowTooltipOn="MouseLeftButtonDown"                                  
                                    ShowAxisLabels="True" />
      <s:SeriesSelectionModifier ReceiveHandledEvents="True" />
    </s:ModifierGroup>
  </s:SciChartSurface.ChartModifier>

Any hints on how to get rid of them?

After upgrade to 4.0

Images
  • You must to post comments
1
0

Hi Robert,

Thanks for getting in touch. Your issues are related to the default chart configuration, which has been changed since v4.0. To switch off the herringbone pattern (axis major bands), please set DrawMajorBands to “False” on your axes. To remove marker’s shadows, you should modify TooltipContainerStyle and RolloverMarkerTemplate, setting Effect to “Null”. Please refer to the Custom Tooltips for modifiers example and our documentation for the guide.

Hope this helps,
Yuriy

  • You must to post comments
0
0

To add to Yuriy’s comment. There is an easier way to disable shadows application wide:

   EffectManager.Instance.EnableDropShadows = false

Thank you! bows

  • You must to post comments
0
0

I added

 EffectManager.Instance.EnableDropShadows = false

to app.xaml.cs, that worked.

And the Herringbone pattern is gone.

Thank you!,
Robert

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.