SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy. We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

Please note: SciChart team will only answer questions from customers with active support subscriptions. Expired support questions will be ignored. If your support status shows incorrectly, contact us and we will be glad to help.

Answered
1
0

Hello again,

I use ZoomPanModifier in my application. I’ve rotated my chart: I’ve set XAxis.AxisAlignment to “Left” and YAxis.AxisAlignment to “Bottom”. I’ve also set YAxis.AutoRange property to “Never”. When I try to pan my chart, the yaxis extends to all data ranges of renderable series.

Is this a bug? Or need I set a flag to make the y-axis not to extend

Thank’s in advance

I’ve attached GIF (if it doesn’t render) and project below.

Images
  • You must to post comments
Best Answer
1
0

Hi Egor,

For horizontal charts, the property ZoomPanModifier.ClipModeX governs whether X-data stretches or gets clipped to extents when panning.

However, for vertical charts, what you need to do is to disable ZoomPanModifier.ZoomExtentsY with this code:

 <s:ZoomPanModifier ZoomExtentsY="False"/>

I’ve tested this with your vertical chart example and it works.

Also, please see this related question which allows you to extend ZoomPanModifier to add ClipmodeY if you also want it.

Best regards,
Andrew

  • Egor
    Hello, thank you for the fast answer. I’ve tried all ClipModeX options, but it doesn’t make a sense
  • Andrew
    Aha, my apologies. I have investigated your sample and updated my answer. Please see my revised answer above. Best regards, Andrew
  • Egor
    Thank you, that works :)
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.