Pre loader

Can't use SciChart. Error 'Charting' does not exist in the namespace...


I have a really strange issue in my project with scichart.
After a few tests with your examples I decided to insert a new chart in my project, but I have the error you can see in the image attached. My application target framework is 4.5.
I made some test, remove/insert the scichart references, tried with the lib\net45 but nothing has worked.
I recently updated my release at 4.03.8086 version.
I dont really know what else to do.
do you have any idea?

Additional informations, from my .csproj

  <Reference Include="SciChart.Charting, Version=, Culture=neutral, PublicKeyToken=b55dd9efe817e823, processorArchitecture=MSIL" />
    <Reference Include="SciChart.Core, Version=, Culture=neutral, PublicKeyToken=b55dd9efe817e823, processorArchitecture=MSIL" />
    <Reference Include="SciChart.Data, Version=, Culture=neutral, PublicKeyToken=b55dd9efe817e823, processorArchitecture=MSIL" />
    <Reference Include="SciChart.Drawing, Version=, Culture=neutral, PublicKeyToken=b55dd9efe817e823, processorArchitecture=MSIL" />
    <Reference Include="SciChart.Drawing.DirectX, Version=, Culture=neutral, PublicKeyToken=b55dd9efe817e823, processorArchitecture=MSIL" />
  • You must to post comments
Best Answer

Thanks for your reply Andrew.

After spending a day. I found out the reason.
I don’t know why but, after removing .scichart at the end of my namespace, everything works well

  • Andrew Burnett-Thompson
    Oh I know. We had a similar problem. Visual Studio again gets confused. If you have a type with namespace A.B.C and you call another type or namespace C, it thinks its part of A.B.C and throws an error. Annoying I know!! We had this problem bigtime when we migrated namespaces between v3.x and v4.x. Sorry I didn’t think of it, but glad you have it sorted!!
  • You must to post comments

This error basically means your Visual Studio project is corrupted or otherwise in a mess. This error does not occur in a new project (you can confirm this if you want).

Usually you have a mix of .NET4.0 and .NET4.5 assemblies in the project, or the Bin/Obj folders contain an older version of SciChart (and Visual Studio is picking them up), or the designer process is still alive and referencing an older versio of SciChart, or Visual Studio is otherwise referencing a mix & match of SciChart versions.


  1. Close all designer windows in Visual Studio in all processes.
  2. Kill all Microsoft Xaml Designer processes in the Task Manager.
  3. Clean your project
  4. Delete all bin/obj folders throughout your project.
  5. Now go through your project and check every DLL of SciChart references the same Runtime version. you can see it in the properties window. We ship .NET4.0, 4.5 and 4.6 versions of the DLL.
  6. Make sure every DLL of SciChart in your project references is referencing the same version/build of SciChart. Sometimes you can reference SciChart from a folder, but Visual Studio picks it up from somewhere else. you can use the HintPath and SpecificVersion property in the csproj to specify the directory to get them from.

Finally, by far the least error prone is to use the NuGet Package Manager and Install-Package SciChart 🙂

Best regards,

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.

Try SciChart Today

Start a trial and discover why we are the choice
of demanding developers worldwide

Start TrialCase Studies