SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, iOS Chart, Android Chart and JavaScript Chart Components

0
0

Hi ,

I am facing a issue with the tooltips.When the scichart surface width is small or the window that has the scichartsurface is small the tooltips are not coming out of chart surface. I can reproduce the issue in Scichart sample(CustomTooltipsWithModifiers) also.

I even tried setting ClipModifierSurface =”False” ClipToBounds=”False”, but no luck. I still have the issue.

FYI , I am attaching the .png files. I cannot attach the sample project here because the allowed upload size is smaller.

Thanks,
Rakesh Bandari.

Version
v4.2.3.10185
Images
  • You must to post comments
0
0

Hello, I am facing the same issue:

We are using several SciChartSurfaces in a Grid, with their own Y axes and a shared X axis for the location.
We add a custom TooltipModifier to each Chart.
Setting ClipModifierSurface=”False” on the SciChartSurfaces allows the Tooltip to be shown while hovering over the Y axis.
On the right side of the chart the tooltip stays within the boundaries of its parent SciChartSurface. But on the bottom the tooltip is cut off where the parent SciChartSurface ends (and a different Surface begins).
Is it possible to show the tooltip outside its parent SciChartSurface?
If not, perhaps there is a way to make the tooltip stay entirely inside the parent boundaries, so it behaves like on the right side?
I tried the following:

  • Override the SciChartSurface template so ChartModifierSurface is set higher in the visual tree than the Axes,
    then set Grid.ZIndex high on ChartModifierSurface
  • TooltipUsageMode=PopUp

Thank you for any advice.

  • You must to post comments
0
0

Hi Rakesh

If the chart is that small, there isn’t really much we can do about this. Tooltips are hosted inside the chart itself (not using WPF Tooltip overlays).

Can you share a bit more information about your use-case? Perhaps we can provide an alternative solution.

Best regards,
Andrew

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.