SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and iOS Chart & Android Chart Components

0
1

We have big trouble with SciChart 6.1. First was the initial loading time. But there is this async loading workaround.
Now if we try to render a simple (not large) signal into the chart, it hangs in the rendering loop. No exception, high CPU usage.
Any solution for this issue?
enter image description here

It works on some, but it fails on most of our PCs/Laptops.

Version
SciChart.6.1.1.13136
Images
  • You must to post comments
0
0

Everything works fine if I deactivate the VisualXcceleratorEngine.
s: VisualXcceleratorEngine.IsEnabled = “False”
But then only slow WPF software rendering is supported.

  • You must to post comments
0
0

We’d need your code to try to debug this Tobias. SciChart’s rendering is single-threaded, any deadlocking is likely occurring because of threads in your code.

The Async license loading is the only place in the scichart library where a new Task is created. This task has to be awaited before you can start your first chart. Also, you should note that SciChart 6.2 (available in nightly build now, full release soon) has a 28x faster startup performance time, and async license loading will no longer be needed.

Can you supply code to reproduce the issue? As I said, we need this because no-one else is reporting such an issue.

Best regards,
Andrew

  • You must to post comments
0
0

Andrew, thanks for your answer.
Ok, it’s not a deadlock or livelock, it just hangs in the rendering loop with high CPU usage. Of course, all calls to SciChart from our software use MVVM bindings and therefore use the UI thread.

I updated to the nightly build version and now I get an exception:
enter image description here

Unfortunately, we do not have time to investigate this issue at the moment. We are reverting to version 5.3 and will try to update later. I would be happy about a possible solution and test it immediately 🙂

Images
  • Andrew Burnett-Thompson
    Just out of interest what video card do you have? Can you use DXDiag.exe and report on the VRAM of the video card? If less than 256MByte then you may have to force DirectX9 mode, which uses less memory.
  • You must to post comments
0
0

Yeees 🙂 Thats it. Thank you Andrew!

Laptops usually have two graphics cards. The laptop on which SciChart hangs/crashes has an Intel and an NVIDIA card. The NVIDIA driver was configured in the NVIDIA control panel to automatically select the required graphics card. However, the NVIDIA card was never selected on these laptops. The VRAM is therefore only 112 MB in size.

Display Devices:

Card name: Intel(R) HD Graphics Family
DAC type: Internal
Device Type: Full Device (POST)
Display Memory: 2160 MB
Dedicated Memory: 112 MB
Shared Memory: 2048 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
HDR Support: Not Supported
Display Topology: Internal

Card name: NVIDIA GeForce GT 750M
DAC type: Integrated RAMDAC
Device Type: Render-Only Device
Display Memory: 10150 MB
Dedicated Memory: 2009 MB
Shared Memory: 8141 MB
Current Mode: Unknown
HDR Support: Unknown
Display Topology: Unknown

SciChart has the “s:VisualXcceleratorEngine.FallbackType” and “DowngradeWithoutException” setting. Although both are set accordingly, the application crashes with the exception “AccessViolationException”.
If DowngradeWithoutException=true, SciChart should never crash or hang the entire application!

If I manually set the NVIDIA card as the default in the NVIDIA Control Panel, everything works fine.

Can you automatically choose the best graphics card available for SciChart?

  • You must to post comments
0
0

I am experiencing the exact same symptoms as the OP, whenever I disable the “Visual Xccelerator Engine” the issue is no longer present. I am also on a laptop. When specifying the dedicated GPU the issue goes away.

  • You must to post comments
0
0

Hey everyone

I’m glad to hear the suggestion of using dedicated GPU instead of integrated Intel HD graphics worked!

We have had a lot of people report similar issues. We published a KB article only yesterday to deal with this kind of issue. Read Troubleshooting Visual Xccelerator Engine Issues on low-end Graphics Adapters

Essentially, Intel HD Integrated Graphics does not have enough VRAM to
use Visual Xccelerator Engine. It may start up but it may also crash or hang during operation, since this engine requires at least 80MB of VRAM for static buffers, and further memory for your other apps.

As a result we are publishing a version very soon (v6.2.0) which will include auto detection of this GPU type and downgrade to DirectX9 mode, which uses less RAM (at expense of performance), or software rendering.

To fully avoid these problems, ensure that you have a video card with at least 256MB of VRAM (more is better) and if you have multiple graphics adapters select the most powerful one to run SciChart with Visual Xccelerator.

Best regards,
Andrew

  • You must to post comments
Showing 6 results
Your Answer

Please first to submit.