SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and iOS Chart & Android Chart Components

0
0

This issue was reported on support tickets by a customer, and we are duplicating here for the community.

Our application use SciChart, it runs normal on most of PCs, but there is one PC which runs the application threw an exception, please see below log info.

2020-07-03 08:08:21,091 [1]-[OnUnhandledException] ERROR Exception has been thrown by the target of an invocation.
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> System.Windows.Markup.XamlParseException: Set property ‘SciChart.Charting.VisualXcceleratorEngine.IsEnabled’ threw an exception. —> System.Exception: Your GPU is blacklisted for use by the Visual Xccelerator Engine! There are several reasons why a GPU could belong to the blacklist. For example, low computation capabilities of the GPU could cause Timeout Detection and Recovery of Graphics Adapter Drivers by the OS, resulting in crashing the application. at SciChart.Charting.VisualXcceleratorEngine.ivc(DependencyObject t, DependencyPropertyChangedEventArgs u) at System.Windows.DependencyObject.OnPropertyChanged(DependencyPropertyChangedEventArgs e)

what should I do? how to resolve this issue?

Version
6.2.0
  • You must to post comments
0
0

The error is in the message shows the cause of the problem and the resolution is below

‘System.Exception: Your GPU is blacklisted for use by the Visual Xccelerator Engine! There are several reasons why a GPU could belong to the blacklist. For example, low computation capabilities of the GPU could cause Timeout Detection and Recovery of Graphics Adapter Drivers by the OS, resulting in crashing the application.’

Blacklisted GPUs are those that we found don’t have enough video memory to run the Visual Xccerator engine, or whose drivers we found have bugs or issues that cause visual problems in SciChart.

To avoid this exception , please set the following properties in this order:

    <s:SciChartSurface s:VisualXcceleratorEngine.DowngradeWithoutException="True" // set this FIRST
               s:VisualXcceleratorEngine.FallbackType="{x:Type s:HighSpeedRenderSurface}" // Set this SECOND 
               s:VisualXcceleratorEngine.IsEnabled="True" // Set this LAST 
     >

It is also possible by bypass this warning if you want to force VisualXccelerator to run by setting the property

    <s:SciChartSurface s:VisualXcceleratorEngine.AvoidBlacklistedGpu="False">

Before any others

Best regards,
Andrew

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.