SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, iOS Chart, Android Chart and JavaScript Chart Components

1
1

Hi

I have multiple SciChartSurfaces aligned using the HorizontalGroupHelper. I also need to have multiple y-axes in the charts. I was hoping to use set the margin on each y-axis, but when I do, the upper axis is drawn outside the window. Is there a work-around?

Example.

<Window x:Class="ScichartTest.MainWindow"
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
xmlns:s="http://schemas.abtsoftware.co.uk/scichart"
Title="MainWindow"
Width="800"
Height="450">

<Grid>
    <Grid.ColumnDefinitions>
        <ColumnDefinition />
        <ColumnDefinition />
    </Grid.ColumnDefinitions>

    <!--  Chart left  -->
    <s:SciChartSurface s:HorizontalGroupHelper.HorizontalChartGroup="group">

        <s:SciChartSurface.XAxis>
            <s:NumericAxis
                AxisAlignment="Left"
                AxisTitle="x" />
        </s:SciChartSurface.XAxis>

        <s:SciChartSurface.YAxes>
            <s:NumericAxis
                Margin="0,0,0,12"
                AxisAlignment="Top"
                AxisTitle="Left y1"
                Id="LeftY1" />
            <s:NumericAxis
                Margin="0,0,0,12"
                AxisAlignment="Top"
                AxisTitle="Left y2"
                Id="Lefty2" />
            <s:NumericAxis
                Margin="0,0,0,12"
                AxisAlignment="Top"
                AxisTitle="Left y3"
                Id="LeftY3" />
        </s:SciChartSurface.YAxes>

    </s:SciChartSurface>

    <!--  Chart right  -->
    <s:SciChartSurface
        Grid.Column="1"
        s:HorizontalGroupHelper.HorizontalChartGroup="group">

        <s:SciChartSurface.XAxis>
            <s:NumericAxis
                AxisAlignment="Left"
                AxisTitle="x" />
        </s:SciChartSurface.XAxis>

        <s:SciChartSurface.YAxes>
            <s:NumericAxis
                AxisAlignment="Top"
                AxisTitle="Right y1"
                Id="RightY1" />
        </s:SciChartSurface.YAxes>

    </s:SciChartSurface>

</Grid>

enter image description here

Version
6.3.0.13476
  • You must to post comments
0
0

Hi Jørgen,

Thanks for your inquiry. I am sorry for the late reply.
Could you please also send us a small sample project reproducing the issue for investigation?
You can also submit this as a support ticket here:
https://support.scichart.com/index.php?/Tickets/Submit

Thanks in advance.

With best regards,
Oleksandr

  • Jørgen Syvertsen
    Thank you for the reply. I have submitted it as a support ticket.
  • Oleksandr Shvets
    Hi Jørgen, Thank you for submitting a ticket. I’ll duplicate the solution here: setting the Height property on YAxis instead of the Margin fixes the issue. With best regards, Oleksandr
  • You must to post comments
0
0

We also have issues with charts bound by HorizontalGroupHelper.HorizontalChartGroup. The bound charts sometimes renders outside of it’s container. If we remove the group it stays inside, but then the charts aren’t aligned anymore.

One of the chart views is inside a tab control. If we switch back and forth between the chart tab and some other tab, the plot renders inside and outside it’s container every other time we go back to the chart tab.

This started happening when switching from SciChart v3 to v6.3.0.13476.

  • Oleksandr Shvets
    Hi Atle, Thanks for your inquiry. This sounds like a different issue. Could you please also submit this as a support ticket here: https://support.scichart.com/index.php?/Tickets/Submit and attach the sample project reproducing this for investigation? Thanks in advance, Oleksandr
  • Atle Rudshaug
    I’ve tried to create a sample project to reproduce, but haven’t been able so far. We also have another chart view with 2 plots linked by HorizontalChartGroup which renders outside it’s container. So it seems there’s something going on when they try to align and one of the charts gets pushed outside it’s original boundary.
  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.