SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, iOS Chart, Android Chart and JavaScript Chart Components


Could anyone explain me what’s that about these errors?

‘Mocks_SciChart_Charting_Visuals_SciChartOverview_0_166924839_8_24014362’ TargetType does not match type of element ‘SciChart_Charting_Visuals_SciChartOverview_0_166924839’

The value “Spectrium.Chart.Modifiers.Spectrogram.SpectrogramSelectionModifier” is not of type “Mocks.SciChart_Charting_ChartModifiers_IChartModifier_0_166924839” and cannot be used in this generic collection.

The first one is caused by

<LinearGradientBrush x:Key="MountainAreaBrush" StartPoint="0,0" EndPoint="0,1">
    <GradientStop Offset="0" Color="#33006400" />
    <GradientStop Offset="1" Color="#E5006400" />

<Style x:Key="OverviewScrollbarStyle" TargetType="s:SciChartScrollbar">
    all setters are omited for brevity

<Style x:Key="OverviewStyle" TargetType="s:SciChartOverview"> <-- this style cause an error
    <Setter Property="Fill" Value="{StaticResource MountainAreaBrush}"/>
    <Setter Property="ScrollbarStyle" Value="{StaticResource OverviewScrollbarStyle}"/>
    <Setter Property="Stroke" Value="#FF279B27"/>

The second by

    <s:ModifierGroup s:MouseManager.MouseEventGroup="CustomGroup">

Of course “m” namespace is defined.

After building all these errors disappear but just right after I click on .xml file int the solution explorer the errors are shown again.

Best regards

  • You must to post comments

Very very wierd.

Can you try our latest nightly build of SciChart? v4.0.5.8215.

We had a wierd issue where someone had included (mistakenly) Rhino.Mocks.dll in the SciChart.Charting package.

To get the latest nightly build, please see here

  • w b
    I get a similar error using v3.6.1.8243. The error only appears in the XAML design panel, but it prevents the designer from loading the rest of the UI elements. When I run the application, I don’t get any errors and everything works as expected. I’m not ready to make the jump to v4 yet. And this error makes it painful to do any UI work (i.e. having to run the application every time a visual element is changed). Is there any fix for this? Our application is built for the x86 platform. I tried switching the the ‘AnyCPU’ platform as Marek suggested above, but I continue to get the same error.
  • Andrew Burnett-Thompson
    I have removed the reference from build v3.6.1.8262 which is going through the nightly build step now.. Should be availbale soon
  • w b
    Updating to v3.6.1.8262 seems to have fixed the issue. Thanks!
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.