SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, iOS Chart, Android Chart and JavaScript Chart Components

0
0

Hi,

we updated to version 6.3 and since then the VisualXcceleratorEngine is no longer used. The fallback type ‘HighQualityRenderSurface’ is always used. What about the auto-select feature for the best GPU?

This is the code we use to check whether DirectX is used:

using (var sciChartSurface = new SciChartSurface())
{
    sciChartSurface.OnRenderException += OnSciChartRenderException;

    VisualXcceleratorEngine.SetIsEnabled(sciChartSurface, true);
    VisualXcceleratorEngine.SetFallbackType(sciChartSurface, typeof(HighQualityRenderSurface));
    VisualXcceleratorEngine.SetDowngradeWithoutException(sciChartSurface, false);
    VisualXcceleratorEngine.SetEnableImpossibleMode(sciChartSurface, true);

    if (sciChartSurface.RenderSurface.GetType() == typeof(VisualXcceleratorRenderSurface))
    {
        // DirectX is enabled!
        retval = true;
    }
    else
    {
        // Restart 2D engine with D3D9   
        VisualXcceleratorRenderSurface.RestartEngineWith(DirectXMode.DirectX9c);

        // For 3D Charts only: Restart 3D engine with D3D9
        //Viewport3D.Restart3DEngineWith(DirectXMode.DirectX9c, FullScreenAntiAliasingMode.None, true);

        VisualXcceleratorEngine.SetIsEnabled(sciChartSurface, true);
        VisualXcceleratorEngine.SetFallbackType(sciChartSurface, typeof(HighQualityRenderSurface));
        VisualXcceleratorEngine.SetDowngradeWithoutException(sciChartSurface, false);
        VisualXcceleratorEngine.SetEnableImpossibleMode(sciChartSurface, true);

        if (sciChartSurface.RenderSurface.GetType() == typeof(VisualXcceleratorRenderSurface))
        {
            // DirectX is enabled!
            retval = true;
        }
    }

    sciChartSurface.OnRenderException -= OnSciChartRenderException;
}

What can I do?

Regards

Version
6.3
Attachments
  • You must to post comments
0
0

Hi SciChart Team,

is this a known issue or am I doing somethin wrong here?

is this issue related to https://www.scichart.com/questions/wpf/visualxcceleratorengine-fallbacktype-is-not-used ?
Problem was the multiple graphic cards and the Intel HD Graphics 4600.

It is difficult for us to revert to an older version of SciChart as it has other bugs. But now only software rendering is possible on all our systems.

regards

P.S.: this time I want to say something positive too, not just about bugs and issues -> SciChart is a great chart 🙂

  • You must to post comments
0
0

Hi Tobias,

Thanks for your inquiry.
We’ve already included a blacklist of unsupported GPUs into SciChart.

From the output you’ve shared recently it looks like the IsEnabled flag is set for the VisualXcceleratorEngine on a disposed instance of a SciChartSurface.
​Could you please run our examples on that PC and check whether VisualXcceleratorEngine is used. If it is, the issue is somewhere in the app most probably. We will need a small sample project reproducing the issue for investigation.

Thanks in advance,
Oleksandr

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.