SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy. We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

Please note: SciChart team will only answer questions from customers with active support subscriptions. Expired support questions will be ignored. If your support status shows incorrectly, contact us and we will be glad to help.

Answered
1
0

Hi,

some time I got this exception if data series are empty:

SciChartSurface didn't render, because an exception was thrown:
  Message: Der Index war außerhalb des Arraybereichs.

  Stack Trace:    bei A.`1.(Int32 )
   bei A.`1.(Int32 )
   bei A.`1.get_(Int32 )
   bei A.`1.get_Item(Int32 index)
   bei Abt.Controls.SciChart.Model.DataSeries.DataSeries`2.XB(IRange C, SearchMode D, SearchMode I)
   bei Abt.Controls.SciChart.Model.DataSeries.DataSeries`2.WB(IRange C, SearchMode D, SearchMode I)
   bei Abt.Controls.SciChart.Model.DataSeries.DataSeries`2.GetIndicesRange(IRange range)
   bei A..(AxisCollection , IRenderableSeries , RenderPassInfo , IPointResamplerFactory , IDataSeries& , IndexRange& , IPointSeries& )
   bei A..(ISciChartSurface , Size )
   bei A..RenderLoop(IRenderContext2D renderContext)
   bei Abt.Controls.SciChart.Visuals.SciChartSurface.DoDrawingLoop()

I use SciChart 3.1.0.5114

regrads

  • You must to post comments
Best Answer
0
0

Hi Tobias,

We have found and fixed a bug in Fifo Series where GetEnumerator() returned a non-empty IEnumerator when Count() was 0. This was causing an IndexOutOfRangeException() when calling DataSeries.XRange if you had an empty Fifo Series.

This bug is fixed in build 3.1.0.5131, which you can get from our Nightly Build server. Please let us know if the issue is resolved.

Best regards,
Andrew

  • You must to post comments
0
0

Hi Andrew,

yes now it is working again! Thanks for the quick Respons.

Best regards,
Tobias

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.