SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Answered
0
0

Hi,
I have been using scicharts for sometimes now but i always have this problem. I set the visible ranges in X axis, let’s say VisibleRange = “20, 100” and the first time the chart renders all looks well (touches the Y axis and the right edge of the chart), but when I zoom and reset zoom or just double click on the graph (as if am reseting after zoom) I have this gap in between my graph (line graph may be) and the Y axis. Can some one please help me get through this? Thanks in advance.

  • You must to post comments
Best Answer
0
0

Hi Kilosa,

My guess (without seeing your code) is that you have XAxis.GrowBy or YAxis.GrowBy set.

Remove this property and you should get the chart fitting tightly to the available space.

If not, please post some code and we will be glad to help!

Best regards,
Andrew

  • Kilosa Magali
    Thanks Andrew, I had GrowBy in the two axes, all is good after removing them.
  • Kilosa Magali
    Hi Andrew, Would you mind checking my other question related to this one posted just below as an answer to this question but it’s actually a question, decided to attach it to this one instead of posting a whole new question. Thanks in advance.
  • You must to post comments
0
0

Hi Andrew, I have another problem kinda related to the previous one. I am having a chart with a logarithmic XAxis , the Axes are as follows

<s:SciChartSurface.XAxis>
   <s:LogarithmicNumericAxis DrawMajorBands="False" AxisMode="Logarithmic" VisibleRange="0.01,11" DrawMinorGridLines="False" DrawMajorGridLines="False"/>

</s:SciChartSurface.XAxis>

<s:SciChartSurface.YAxis>
  <s:NumericAxis  DrawMinorGridLines="False"  DrawMajorGridLines="False" AxisAlignment="Left" />

</s:SciChartSurface.YAxis>

The problem is the chart doesn’t show unless I add XAxis.GrowBy (strictly in the XAxis), and by doing so I can’t reset my chart after zoom as in the previous question (It only restores in the YAxis but not Xaxis). That happens in all of my charts with logarithmic axes, I have no clue of what might be the prob, Please help.

  • Yuriy
    Hi Kilosa, could you try setting AutoRange to “Never” on the LogAxis? You should do this when setting VisibleRange manually.
  • Kilosa Magali
    Hi Yuriy,I have tried that on my logarithmic axis , even tried the other possible values of AutoRange , unfortunately it didn’t do the trick. And as I said before, if i remove GrowBy from the logAxis I dont have the graph at all.
  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.