SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

0
0

Hi,

I cannot remove a shadow effect from AxisLabelControl (see attached image).

This is the style I am using:

<Style x:Key="CursorModAxisLabelStyle" TargetType="s:AxisLabelControl">
            <Setter Property="Background" Value="#FF202020" />
            <Setter Property="BorderBrush" Value="#FF8A8A8A" />
            <Setter Property="BorderThickness" Value="1" />
            <Setter Property="Opacity" Value="1.0"/>
            <Setter Property="Effect" Value="{x:Null}"/>
</Style>

and this line is added to both NumericalAxis:

 s:CursorModifier.AxisLabelTemplate="{StaticResource CursorModAxisLabelTemplate}"

I am fine with shadow effects on other components, but a shadow on that particular label is annoying and seems unnecessary.

Any help would be appreciated!

Thanks

Version
4.6.2
Images
  • You must to post comments
1
0

I ran into the same problem. Correct me if I’m wrong, but is there a default effect applied inside the template of the default AxisLabelControl? And if that’s the case, what’s the reason behind it?
Can you at least provide the default ControlTemplate for the AxisLabelControl? I can’t find it either in the examples or the resources you made available online. I can only find styles for it, but there if I set the Effect property to {x:Null}, as someone already suggested here, it has no effect. By the way, I think that should be considered a bug. Wouldn’t a simple TemplateBinding of the Effect property inside the ControlTemplate of the AxisLabelControl fix the problem? Now you suggested to switch off all drop shadows, but that also effects the tooltips of the rollover modifier for instance and I can imagine use cases where you might want to be able to set them independently.

  • You must to post comments
0
0

Hi Stefano

In SciChart v4 you can disable all tooltip shadows using the property:

EffectManager.Instance.EnableDropShadows = false

In ScIchart v5, you can disable the tooltips, OR, style/theme the tooltip shadow, using the stylekey ShadowEffectColor (expects type Color). See this article for instructions how to override just one color in a theme.

Best regards,
Andrew

  • Denis Denis
    I’m just curious why does Setter Property=”Effect” Value=”{x:Null}” not work?
  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.