SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy

We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

0
0

Hello

I have a problem trying to get SciChartOverview to update when the SciStockChart changes. My code is basically works as follows:

SciChart is in a ContentTemplate in a ContentControl which displays a loading animation while data is computed and loaded. When that finishes the ContentControl switches to the SciStockChart & SciChartOverview and data is added to the SciStockChart using chartPaneView.RenderableSeries.Add. The first time it runs everything works correctly. But when I remove all renderable series from the chart and add new ones the SciChartOverview is wrong. The order of execution is as follows remove all renderable series -> switch to loading animation -> display SciChart -> add new data. Image attached.

            <s:SciChartOverview
            Grid.Column="1"
            s:ThemeManager.Theme="SciChartV4Dark"
            ParentSurface="{Binding ElementName=chartPaneView}" 
            SelectedRange="{Binding ElementName=chartPaneView, Path=XAxis.VisibleRange, Mode=TwoWay}" />
Version
4.1.2
Images
  • You must to post comments
0
0

HI Paul R,

Thank you for reporting the issue.

I’ve reproduced it. And I logged it.

Best regards,

Markiyan

  • You must to post comments
0
0

Thanks.

  • You must to post comments
0
0

Hi Paul,

Sorry for delayed response.

This issue has been fixed. Please, get new version from NuGet.

Best regards,

Markiyan

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.