SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy. We also have a tag=SciChart on where you can earn rep for your questions!

Please note: SciChart team will only answer questions from customers with active support subscriptions. Expired support questions will be ignored. If your support status shows incorrectly, contact us and we will be glad to help.


When I insert a series of data (more than 100 data)into the graph, the application crashes
Source code is as follows


The error is as follows

java.lang.UnsupportedOperationException: Data has been changed to a DataSeries which is unsorted in the X-Direction. Unsorted data can have severe performance implications in SciChart.

For maximum performance, please double-check that you are only inserting sorted data to SciChart. Alternatively, to disable this warning and allow unsorted data, please call dataSeries.setAcceptsUnsortedData(true).

I set up “dataSeries.setAcceptsUnsortedData (true)”, but still reported wrong.
how to solve it?

  • You must to post comments

Hi Huang,

Are you sure that you set AcceptsUnsortedData for all data series which contain unsorted data? As I see you have multiple data series instances so maybe you didn’t set AcceptsUnsortedData = true for one of them? I’m asking because the exception about unsorted data should be thrown only if data series instance contains unsorted data in X direction and its AcceptsUnsortedData = false.

If you checked your code and you’re sure that all data series with unsorted data have AcceptsUnsortedData = true then I want to ask you to post an example which reproduces this issue so I can debug it on my PC.

Best regards,

  • You must to post comments

I checked again and found that there was a missing place and the problem was solved

  • Yura Khariton
    Hi Huang. I’m very glad that issue is resolved.
  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.