SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and iOS Chart & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy. We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

Please note: SciChart team will only answer questions from customers with active support subscriptions. Expired support questions will be ignored. If your support status shows incorrectly, contact us and we will be glad to help.

0
0

I am creating the dynamic Numeric Y axis. Tthese are the attributes i am setting

axis.VisibleRange = new VisibleRange (0, 100) 
axis.AxisTitle = axisViewModel.Title; 
axis.AutoRange = AutoRange.Never 
axis.AxisAlignment = axisViewModel.AxisAlignment; 
axis.BorderBrush = axisViewModel.BorderBrush; 
axis.BorderThickness = axisViewModel.BorderThickness; 
axis.TextFormatting = axisViewModel.TextFormatting; 
axis.DrawMajorGridLines = axisViewModel.DrawMajorGridLines; 
axis.DrawMinorGridLines = axisViewModel.DrawMinorGridLines; 
axis.DrawMajorTicks = axisViewModel.DrawMajorTicks; 
axis.DrawMinorTicks = axisViewModel.DrawMinorTicks; 
axis.GrowBy = axisViewModel.GrowBy; (0.1, 0.1) 
axis.TickTextBrush = axisViewModel.TickTextBrush; 

still it is auto ranging. Am I missing some attribute

  • You must to post comments
0
0

Hi Harishtei,

AutoRange.Never means exactly that: never autorange. If you are setting a VisibleRange and setting AutoRange.Never, the YAxis will not autorange. Unless ….

  • You call SciChartSurface.ZoomExtents()
  • You use RubberBandXyZoomModifier with IsXAxisOnly = true
  • You override ViewportManager and set your own ranging algorithm
  • You later set AutoRange to Once or Always
  • You set an invalid range (for instance, VisibleRange=0,100 is valid on NumericAxis, but not valid on LogarithmicNumericAxis).

Perhaps you can check your code again?

Best regards,
Andrew

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.