SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, iOS Chart, Android Chart and JavaScript Chart Components

0
0

pointMarker max and min values marker are cropped when autoRange is enabled. Check the attached image.

Version
1.2.1452
Images
  • You must to post comments
0
0

Hi Arun

The AutoRange algorithm in SciChart calculates the data-point position, It does not take into account the size of the pointmarker.

You can provide a little padding to the axis by setting the GrowBy property:

    const yAxis = new NumericAxis(wasmContext);
    yAxis.growBy = new NumberRange(0.1, 0.1);

This means ‘Apply a padding of 10% to the top and 10% to the bottom of the YAxis.

Try a small number like 0.05 or 0.01 and see if it makes the visual appearance better.

Best regards,
Andrew

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.