SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and now iOS Charting & Android Chart Components

Welcome to the SciChart Community Forums!

Please use the forums below to ask questions about SciChart. Take a moment to read our Question asking guidelines on how to ask a good question and our support policy. We also have a tag=SciChart on Stackoverflow.com where you can earn rep for your questions!

Please note: SciChart team will only answer questions from customers with active support subscriptions. Expired support questions will be ignored. If your support status shows incorrectly, contact us and we will be glad to help.

0
0

Hi All,
I am having an issue with legend as legend box is displays on chart and its also display series name on it but colors are not coming in legend only series name is displayed.
I also attached a IMAGE showing the above issue.

Images
  • You must to post comments
1
0

Hi there,

I think that this could be caused by setting LegendModifier.ShowSeriesMarkers = false.

If you’re creating LegendModifier by your own I would suggest to ensure that you have ShowSeriesMarkers = true.

If you’re using SciStockChart (extension of SciChartSurface which provides default set of modifiers) then you could set this property via SciStockChart.LegendStyle:

    <Style TargetType="s:LegendModifier" x:Key="legendStyle">
        <Setter Property="Margin" Value="5"/>
        <Setter Property="Orientation" Value="Horizontal"/>
        <Setter Property="ShowSeriesMarkers" Value="True"/>
        <Setter Property="ShowVisibilityCheckboxes" Value="False"/>
    </Style>

  <s:SciStockChart ShowLegend="True" LegendStyle="{StaticResource legendStyle}" ...>
          ...
  </s:SciStockChart>

Hope it helps!

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.