Pre loader

The tag 'SciChartSurface' does not exist in XML namespace ''


We often get asked for technical support about the following error message:

The tag ‘SciChartSurface’ does not exist in XML namespace ‘’

If you have this problem please post below with what you’ve tried and your solution (if applicable).

We believe this problem is related to a mismatch between .NET Framework versions. For instance,

  • Referencing the SciChart WPF .NET4.0 DLL in a .NET3.5 or .NET4.0 Client Profile project
  • Referencing the Scichart WPF .NET4.5 DLL in a .NET4.0 project

Please ensure the version of SciChart that you reference matches the Framework Version of the target project.

  • You must to post comments

More evidence to suggest this error is a cryptic message meaning a mismatch between .NET Framework versions

StackOverflow: The tag “xxx” does not exist in XML namespace“yyy” / Reference could not be found

The solution is: Go to your project properties and change the Target
Framework from Client Profile to the full version of the .Net you are
using, see the image below. This problem happens if your DLL targets
the full .NET Framework, and your WPF Application (main project)
targets .Net Client Profile.

enter image description here

The error appears to occur when the project .NET Framework is lesser than the DLL .NET Framework

  • You must to post comments

Hi Everybody,

i recently had this problem. I’m not 100% sure what solved it but finally it’s working again.
So i decided to share my steps. Maybe this will help someone too.
First: I also had a second issue. So during the steps i needed to change the rootNamespace in my project during my steps.
The solution above didn’t worked for me. It already wa full version of .net. I use .net 4.0 scichart dll in a 4.5 project.

  1. I removed the references to Scichart and set them again.(multiple times to be exact)
  2. I removed the obj & bin folder and tried to rebuild it. This started my second problem. So changed the rooNamespace and put the old folders back but after step 4! Which solved it.
  3. i opned the .vbproj file in the editor and checked the HintPath from Scichart.dll. This was ok. But at the end of the file i found some strange:

    <Resource Include="DLL%27s\aktuell\Net40\64\Abt.Controls.SciChart.Wpf.2.2.XML" />
    <Content Include="DLL%27s\aktuell\Net40\86\Abt.Controls.SciChart.Wpf.2.2.dll" />
    <Resource Include="DLL%27s\aktuell\Net40\86\Abt.Controls.SciChart.Wpf.2.2.XML" />
    <Content Include="DLL%27s\aktuell\net45\Abt.Controls.SciChart.Wpf.2.2.dll" />
    <Resource Include="DLL%27s\aktuell\net45\Abt.Controls.SciChart.Wpf.2.2.XML" /> </ItemGroup>

There were also some other external dll in this last section which i deleted to make it more clear. These paths still exists but i don’t use them anymore. Remember the HintPath is correct, but it is not one of these.

So i deleted everything in this Itemgroup. Leaving only <ItemGroup></ItemGroup>. BUT make a copy before to be safe.
4. Again i removed the references ans set them again.
Now its working! I can compile and run it again.
you might saw that i use Version 2.2. I also tried the newest version in step 1 & 4.
now i can run the program with both versions.
BUT when i use the newest version i still get XAML errors: The name “SciChartSurface” does not exist in Namespace “”.
I don’t know why but it compiles and runs. I guess that this is a intelisense problem. Also my second issue could be a VS bug. There are plenty of stackoverflow questions about this:

I’m not 100% sure if this is helping someone but i decided to share the steps.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.

Try SciChart Today

Start a trial and discover why we are the choice
of demanding developers worldwide

Start TrialCase Studies