Pre loader

Zoom not working properly on one single computer

Welcome to the SciChart Forums!

  • Please read our Question Asking Guidelines for how to format a good question
  • Some reputation is required to post answers. Get up-voted to avoid the spam filter!
  • We welcome community answers and upvotes. Every Q&A improves SciChart for everyone

WPF Forums | JavaScript Forums | Android Forums | iOS Forums



Got a wierd issue. My client is installing my application (built with Scichart) and everything works fine, except on the laptop of this one particular guy, where the zoom does a wierd thing. It zooms the axes, but the graph is not moving. I’m quite sure there is nothing wrong with my application as it works everywhere else, but can any of you think of anything that I should check on this guys machine? I am at a complete blank here…

Thanks for helping me out….

  • You must to post comments
Best Answer

Hey guys,

We actually have a reproduction of this bug that occurs on some computers – without using SciChart.dll. It appears to be an issue with some Intel Graphics drivers and WriteableBitmap / .NET4/4.5.

Please download the attached solution and run it on computers where you see problems. Click on the main form. If all is working, you should see a coloured square drawn, which changes colour on each click. However, in systems with this problem, the form will be blank.

What we believe is happening is the WriteableBitmap once locked/unlocked once is not allowing any further updates. The same code works perfectly well on many other machines and the only other workaround is to disable hardware rendering for the WPF process on systems that exhibit this problem.

We have contacted Microsoft and Intel to see if any will take ownership of the fix. In the meantime, as a workaround you will have to disable WPF hardware rendering for the process.

Best regards,

  • You must to post comments

So I might have a solution for this. The machine in question was restarted in safe-mode and then the application was started and worked fine. So it had to be some kind of driver issue right? So there was an intel-driver for an onboard graphics card that was the cause of the whole issue. This driver was uninstalled and again it was working fine. Downloaded and installed a new updated driver and now everything works fine.

So anyone else having this issue, try running the application in safe-mode. If the zoom works fine in safe-mode, chances are you may have the same buggy driver installed. Check for updates for that graphics driver.

Hope this helps

Best regards,

  • Andrew Burnett-Thompson
    Wow ... That is awesome - so you have the problem resolved Lisbeth? Chuck - can you try and run through these steps and confirm if you see the same? (Working chart in Safe Mode).
  • Tobias
    I have the same issue only on this Ultrabook. I installed the newest graphic driver but no success.
  • bstapylton
    We have had two cases of this issue in different client environments. I can't report many details on the first occurrence other than that this thread made us suggest the user try updating their graphics drivers, they did and problem solved. The second occurrence was interesting as the user could run our UI on one of her three monitors and not have any problems, but on the other two screens the SciChart wouldn't render on zooming or updating data. The problem monitors were plugged into the onboard graphics card. Device Manager revealed the onboard device was "Intel(R) HD Graphics 4600" with a driver signed on 6/03/2013, with driver version The third monitor was being run from an external AMD video card and was having no problems.
  • Andrew Burnett-Thompson
    Strange. I actually have a computer with Intel HD 4000 (similar) and no problems. The other strange thing is we are doing nothing related to DirectX or hardware acceleration, nothing other than what WPF does by itself, so I cannot for the life of me think what the problem is. You can try this: it will disable WPF's hardware rendering on your application only. Don't worry, WPF uses hardware acceleration but it won't make too much different to performance, unless you are doing a lot of animation or WPF3D: Disable WPF Hardware acceleration
  • Tobias
    Today I upgraded Windows 8.0 to 8.1 and now everything works fine (Zooming... ). Best regards, Tobias
  • You must to post comments

After disabling WPF Hardware acceleration i get stuck on employee monitoring software graphic drawing process.
So it would be better to turn it on again?

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.