Pre loader

Tag: AxisAlignment

Welcome to the SciChart Forums!

  • Please read our Question Asking Guidelines for how to format a good question
  • Some reputation is required to post answers. Get up-voted to avoid the spam filter!
  • We welcome community answers and upvotes. Every Q&A improves SciChart for everyone

WPF Forums | JavaScript Forums | Android Forums | iOS Forums

0 votes

Hi, if I have multiple graphs stacking on top of one another, is there any way for me to align them by the Y axis on the left?

I noticed that padding is applied to the most outer edge drawn item, so in many cases that would be the label, not the axis.

  • Sen Lin asked 5 years ago
  • last active 5 years ago
0 votes

I have two charts (separate SciChartSurface via SciChartGroup) stacked on top of each other. Each chart has its own X-Axis and both charts’ mouse interaction are linked via MouseGroupId. All fine so far.

I then generate a lineseries ‘series1’ on the first surface, 1000 datapoints, time stamps are 1 minute apart. I also generate a second line series ‘series2′ on the second surface, but this series’ first time timestamp start 2 hours later than the first series.

Expected behavior is that the series2 will be shifted by 2 hours and not start at the same position as series1 but rather extend by 2 hours. That is, however, not the case on my chart.

What is wrong here and is this a potential bug?

I need both XAxes to be perfectly aligned, meaning the cross hair label on each XAxis displays the exact same time stamp. Please note that I customized the LabelProvider to display milliseconds also, but I use the same Label Provider for both charts, so no difference here.

Can someone please chime in what is going on?

Please see attached charts to illustrate what I have been describing (screenshot1 shows intended behavior but on the same chart, I want this behavior to occur on separate panes/charts). Screenshot 2 describes the problem I am having.


  • bbmat asked 7 years ago
  • last active 7 years ago
1 vote

To whom this may concern:

I am having an issue setting the axis alignment with your 2D Heatmap series. I have tested this with your “Heatmap Chart” sample from your Examples Suite.

Lines 44-50 are shown below from your “HeatMapExampleView” XAML file. I have added the AxisAlignment parameters as shown.

    <s:NumericAxis AxisAlignment="Left" DrawMajorBands="True" />

    <s:NumericAxis AxisAlignment="Top" DrawMajorBands="True" />

Note how the Y-Axis is aligned to a vertical parameter (Top, in this case) and X-Axis is aligned to a horizontal parameter (Left). This leads to scichart not showing any heatmap at all, as shown in the attached images.

It will work if i set Y to Left or Right, and X to Top or Bottom, but not the other way around.

Can you please advise?

Thanks kindly!

  • Ari Sagiv asked 8 years ago
  • last active 8 years ago
1 vote

Hello again,

I use ZoomPanModifier in my application. I’ve rotated my chart: I’ve set XAxis.AxisAlignment to “Left” and YAxis.AxisAlignment to “Bottom”. I’ve also set YAxis.AutoRange property to “Never”. When I try to pan my chart, the yaxis extends to all data ranges of renderable series.

Is this a bug? Or need I set a flag to make the y-axis not to extend

Thank’s in advance

I’ve attached GIF (if it doesn’t render) and project below.

  • Egor asked 8 years ago
  • last active 8 years ago
Showing 4 results

Try SciChart Today

Start a trial and discover why we are the choice
of demanding developers worldwide

Start TrialCase Studies