Pre loader

Tag: Grid

Welcome to the SciChart Forums!

  • Please read our Question Asking Guidelines for how to format a good question
  • Some reputation is required to post answers. Get up-voted to avoid the spam filter!
  • We welcome community answers and upvotes. Every Q&A improves SciChart for everyone

WPF Forums | JavaScript Forums | Android Forums | iOS Forums

0 votes
7k views

I use a simple box annotation to highlight a section candlesticks on a chart. Currently I only see how to set this annotation X1 and X2 to Major grid units (ie 1,2,3,4,5). Since I would like to have this box annotation fully highlight only the desired candlesticks, is there a way to offset this X1 and X2 position by 0.5 so that it would include only (and fully) the desired candles? Apologies if I have missed this in the docs somewhere but I have been unable to find anything to accomplish this.

EDIT: For my x axis I am using a CategoryDateTimeAxis

Thank you.

  • Leland asked 4 years ago
  • last active 4 years ago
0 votes
8k views

We currently have up to 4 charts that are stacked vertically and the data flows horizontally. However, we need to reverse it so that they are stacked horizontally and the data flows vertically. We currently have a grid setup for the charts to be set to but I can’t seem to figure out how to reset the Grid.Row and Grid.Column of each SciChartSurface at runtime.

Example:
Horizontally, this is how it looks…

<s:SciChartSurface x:Name="sciChartSurface1" Grid.Row="0" Grid.Column="1">

Vertically, it needs to be this…

<s:SciChartSurface x:Name="sciChartSurface1" Grid.Row="1" Grid.Column="0">

Is this possible to do at runtime/from the backend code?

0 votes
9k views

I have a SciChart WPF control which works as expected when it is in a dedicated window, but if I place it inside of a grid it will not display properly. As you can see in the picture below, it displays the background and Axis properly, but the actual chart itself in the center is very tiny. enter image description here

XAML

<UserControl …
             xmlns:s="http://schemas.abtsoftware.co.uk/scichart">
    <Grid>
        <Grid.RowDefinitions>
            <RowDefinition Height="1*" />
            <RowDefinition Height="Auto" />
            <RowDefinition Height="2*"/>
        </Grid.RowDefinitions>
        <Grid Grid.Row="0">
            Some other stuff
        </Grid>
        <GridSplitter Grid.Row="1" Height="5" HorizontalAlignment="Stretch" />
        <s:SciChartSurface Grid.Row="2" x:Name="SciChartSurface">
            <s:SciChartSurface.XAxis>
                <s:DateTimeAxis AxisTitle="Time"/>
            </s:SciChartSurface.XAxis>
            <s:SciChartSurface.YAxis>
                <s:NumericAxis/>
            </s:SciChartSurface.YAxis>
            <s:SciChartSurface.ChartModifier>
                <s:ModifierGroup>
                    <s:RubberBandXyZoomModifier />
                    <s:ZoomExtentsModifier />
                </s:ModifierGroup>
            </s:SciChartSurface.ChartModifier>
        </s:SciChartSurface>
    </Grid>
</UserControl>
1 vote
0 answers
15k views

Hi,

I think I have found a bug. If LegendModifier has Margin (i.e. 10) it forces ModifierGroup to grow to VisibleWidth/Height 20×20. Than you can clearly see that the modifier group is placed outside the “chart area” and creates additional “topleft margin”.

Setting Grid.Row=”3″ and Grid.Column=”2″ on ModifierGroup looks like a fix.

Thanks

Showing 4 results