Pre loader

3D Chart major grid lines anti aliasing

Welcome to the SciChart Forums!

  • Please read our Question Asking Guidelines for how to format a good question
  • Some reputation is required to post answers. Get up-voted to avoid the spam filter!
  • We welcome community answers and upvotes. Every Q&A improves SciChart for everyone

WPF Forums | JavaScript Forums | Android Forums | iOS Forums


Hi SciChart Team,
Is it possible to turn on anti aliasing for the major grid lines in 3D Surface?
The rendered lines in Chart look good, but the major grid lines look like they are built from the small strokes.

5.4 latest stable
  • You must to post comments

Hi Silvester

I was looking into this for you and found two problems.

There is a method in Viewport3D where you can start the 3d engine with Full Screen Anti Aliasing (if you’ve ever played PC games, you’ll know jagged lines are a problem, and you cannot AA a single line, but you can AA the entire scene).

So, try calling Viewport3D.Restart3DEngineWith() and pass in DirectXMode.AutoDetect, FullScreenAntiAliasingMode.MSAA4x

public static void Restart3DEngineWith( 
  DirectXMode directXMode,
  FullScreenAntiAliasingMode antiAliasingMode,
  bool d3d11UseLowerFeaturesLevel

However the problem. In version 5 of SciChart WPF I noticed this had little effect and in version 6 BETA it causes a crash. We will investigate both.

In the meantime, I suggest setting the line colour to be a little less black, try using some opacity, it will help blend the line Into its background and look less harsh. Many of our themes strategically choose colours to look the best on a variety of hardware.

Let me know if this helps,

Best regards,

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.