SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, and iOS Chart & Android Chart Components

0
0

Hello SciChart,

I’m using SciChart:PerformanceHelper.EnableExtremeResamplers=”True” on my SciChart surface to display data with multiple gaps properly (NaN values), however the XPS output using ExportToFile does not work well and only renders the data to the first gap. Is there a workaround to this issue or how can it be fixed? Thank you.

Kind regards
Ondřej

Version
5
Images
  • You must to post comments
0
0

Hi Ondrej,

Thanks for your inquiry.
Could you please provide us with a small sample project reproducing this issue for investigation?

Thanks in advance.

  • You must to post comments
0
0

Hi Oleksandr,

I will try to derive a small sample project with this issue, that will probably take some time.
I have also noted that other export (bitmap) formats work well.

There is only 4007 values in the series and the gaps are single NaN values. Without the NaNs, everything works fine, even without
ExtremeResamplers.

Kind regards
OH

  • You must to post comments
0
0

Hi Oleksandr,

It seems that the method ExportInternal in SciChartSurfaceBase.Export.cs does not do its job completely well and could be the cause of this problem. In my opinion the code around CreateCloneOfSurfaceInMemory needs to be extended substantially.

At the moment, important chart settings are ignored completely, ExtremeResamplers and specific TickProviders among others which results in bad XPS rendering.

Kind regards
OH

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.