Pre loader

While changing values in DataSeries bound to FastAndRenderableSeries, SeriesInfo holds old data, not new data

Welcome to the SciChart Forums!

  • Please read our Question Asking Guidelines for how to format a good question
  • Some reputation is required to post answers. Get up-voted to avoid the spam filter!
  • We welcome community answers and upvotes. Every Q&A improves SciChart for everyone

WPF Forums | JavaScript Forums | Android Forums | iOS Forums


While I am updating my dataseries, I change the values and I want to update my LineAnnotation (sloped) to use the new Y coordinates on the dataseries. It seems to hold the old value, not the new value.

For example:

The Y value before might be 0.78. I change my data and the new Y value should show 0.05, but instead, when I call sliceModifier.SeriesData.SeriesInfo.Where(x => x.SeriesName == “Series Name”).ToList()[1].YValue, it shows 0.78.

I have tried the following:

It fires and I get to my code behind method and it shows the old value instead of the new

MVVM Light Messenger (event firing from VM):
I change the DataSeries in the VM, then send a message (fire an event) and it gets to my code behind method to update the Y value. It still shows the old value.

I have tried LineAnnotationName.Refresh() and I have tried to access the appropriate Y Values.

What can I do? How do I access these new values?

  • You must to post comments

Hi Ryan,

Thanks for writing to us. Unfortunately, I couldn’t reproduce the issue on our side. Could you please provide more info about your use-case? Which SciChart version do you use? Is it the latest one? Do you have tooltips on VerticalLines visible or hidden? Do tooltips get updated when you drag a line? Please attach some screenshots as well – they usually are helpful when some points are not very clear.

Also If possible, it would be good if you could reproduce this issue in a small project and snd it to us for investigation.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.