SciChart® the market leader in Fast WPF Charts, WPF 3D Charts, iOS Chart, Android Chart and JavaScript Chart Components

0
0

Hello,

I have a line series with 500k to 8 million data points and I use the StrokePaletteProvider to highlight certain peaks in different colors. But the colors only appear right at a certain zoom level, without zooming in it is a mixture of my default line color and the chosen StrokePaletteProvider color. Is there anything I can do about this?

Version
5.4.0.12119
Images
  • You must to post comments
0
0

Anyone?

  • You must to post comments
0
0

Hi Roland,

Thanks for your question.

This issue might happen because of Resampling. Please try to switch it off setting the ResamplingMode property to “None” on your Line series. Does it help?

  • You must to post comments
0
0

Was going to say the same thing as Yuriy, but a little more detail.

When you have five million points, often several datapoints get drawn to the same pixel (called overdraw). We detect this and reduce the number of points at draw time to improve performance.

When you use PaletteProvider you’re operating on this reduced set. This is probably why you setting colors means not all points appear coloured in.

ResamplingMode.None May help you here but it will also make performance really bad.

I’d actually like a code sample of what you have here to reproduce it on our side. I think our new rendering engine in scichart WPF v6 , which has gradient shading between points, may help.

Can you send a code sample over to support (at) scichart .com?

  • You must to post comments
0
0

Thanks for your help,

I wasn’t aware of the auto default value for resampling, setting ResamplingMode.None fixed the problem. But as you mentioned Andrew the performance decreases dramatically.

The code is fairly simple, I just used your example for a custom paletteprovider and added my override stroke color condition.

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.