Pre loader

Stackedcolumnwidth shrinks

Welcome to the SciChart Forums!

  • Please read our Question Asking Guidelines for how to format a good question
  • Some reputation is required to post answers. Get up-voted to avoid the spam filter!
  • We welcome community answers and upvotes. Every Q&A improves SciChart for everyone

WPF Forums | JavaScript Forums | Android Forums | iOS Forums


Hi there,

I am trying to generate a stacked columns chart to display the drivers’ stints during a moorsport race. The problem that I am unable to solve is related to the width of the columns of the graph. Although I am setting datapointwidth = 1.0, so that the column takes all the space, this only happen if I display one driver/column (see images). When adding new driver/columns, the columnwidth of every column shrinks and does not take up all the space (see images). It looks like the datapointwidh follows the next relationship :

Datapointwidth = 1 / Number of Columns

Is there anyway I can force the stackedcolumnrenderableseries to always have a datapointwidth of 1.0?

  • You must to post comments

Hi Miguel,

Thanks for your inquiry.
Setting Datapointwidth property works for Stacked Columns Chart in our examples. Please take a look:

Could you please provide us with a small sample project reproducing this issue for investigation?

Thanks in advance.

  • You must to post comments

Hi Miguel,

I am sorry for the late reply.
Could you please send us a simplified project reproducing the issue? This one you’ve sent is too complex for investigation. You can extend our “Column Chart” example:

Thanks in advance,

  • Miguel Cano
    Hi Oleksandr, Thanks for getting back. Find a very simplified example of my project in the following link: Note that I require to have a serie for each stint of each car. The reason behind it is that the color for each stint/dataserie should be independent of the stint number. Let me know if you can find a solution or if you have any other suggestion. Thanks in advance. Regards, Miguel
  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.